1、安装composer
作为最知名的php第三方库安装工具,drush也支持使用这种方式安装。 composer的安装比较简单。

vim ~/.bashrc 并添加一条

2、安装drush

安装完,如果有Unable to load autoload.php…的错误,编辑

修改includes/preflight.inc,查找$global_vendor_path,修改为$global_vendor_path = DRUSH_BASE_PATH . ‘/../vendor/autoload.php’; 执行命令

如果显示Drush Version : 8.0.0-rc2,则安装成功。 为什么要安装drush?因为drush是一款非常优秀的drupal管理工具,drupal离不开drush。 下文将讲解如何把drupal7的模块转化为drupal8的模块。




HTTPX 基础教程-新乡seo|网站优化,网站建设_微信公众号:zeropython—昊天博客